AnsweredAssumed Answered

phy not found error is coming when booting uboot

Question asked by sameerarvikar on May 8, 2017
Latest reply on May 11, 2017 by sameerarvikar

Using Imx6

I am trying to run ethernet on my custom board

so i am following the below link for my reference

U-Boot Migration Example 

following parameter is

#define CONFIG_FEC_MXC_PHYADDR  0x18

as per output of mii info

 

 

 

following is the console

U-Boot 2015.04-mx6+gf8b4493 (May 08 2017 - 12:24:32)

CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
CPU:   Temperature 30 C
Reset cause: POR
Board: Variscite VAR-SOM-MX6 Quad-PoP 792 MHz
I2C:   ready
DRAM:  1 GiB
PMIC:  PFUZE100 ID=0x10
MMC:   FSL_SDHC: 0, FSL_SDHC: 1
auto-detected panel VAR-WVGA
Display: VAR-WVGA (800x480)
In:    serial
Out:   serial
Err:   serial
switch to partitions #0, OK
mmc0 is current device
eMMC:  7.3 GiB
Net:   phy_mask_from func--getphybymask --> 16777216     // just a print for debug
Phy 24 not found
using phy at 24
got MAC-1 address from fuse: f8:dc:7a:0a:9d:95
FEC [PRIME]
Normal Boot
Hit any key to stop autoboot:  0
=>
=>

If i run mii info

 

=> mii info
PHY 0x18: OUI = 0x01C1, Model = 0x23, Rev = 0x01, 10baseT, HDX
PHY 0x19: OUI = 0x01C1, Model = 0x23, Rev = 0x01, 10baseT, HDX

if i run mdio list

 

=> mdio list
FEC:
24 - Generic PHY <--> FEC
=>

 

 

 

As per the document i need to have vitesse driver and change in include/configs/mx6var_som.h file as i am using vitesse vsc8502 phy

i found vitesse.c but its not having driver for vsc8502

How to get the driver or uboot will find its own generic phy

and why the error is coming phy not found

Outcomes