AnsweredAssumed Answered

Android marshmallow stuck on android boot animation on IMX6SL based custom board

Question asked by Namrata Nalawade on May 2, 2017
Latest reply on May 3, 2017 by Namrata Nalawade

Hi all,

My custom board based on imx6sl is running Android 6.0 but it's stuck at boot animation, only shows "android" on LCD. It couldn't display the complete android UI. After observing the  logs it seems like, the /data and /cache partitions are not getting mounted and are failing with the error- "read only file system". Below is the snippet from the logs - 

############################################################################

fs_mgr: Enabling dm-verity for system (mode 0)
EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: barrier=1
fs_mgr: __mount(source=/dev/block/dm-0,target=/system,type=ext4)=0
fs_mgr: __mount(source=/dev/block/mmcblk0p4,target=/data,type=ext4)=-1
fs_mgr: Failed to mount an un-encryptable or wiped partition on/dev/block/mmcblk0p4 at /data options: (null) error: Read-only file system
fs_mgr: __mount(source=/dev/block/mmcblk0p6,target=/cache,type=ext4)=-1
fs_mgr: Failed to mount an un-encryptable or wiped partition on/dev/block/mmcblk0p6 at /cache options: (null) error: Read-only file system
EXT4-fs (mmcblk0p7): mounted filesystem with ordered data mode. Opts: (null)
fs_mgr: __mount(source=/dev/block/mmcblk0p7,target=/device,type=ext4)=0
init: fs_mgr_mount_all returned an error
init: fs_mgr_mount_all returned unexpected error 255
file system registered

############################################################################

The same same SD card works on IMX6SL evaluation board without any mount errors.  The only difference in the development board and the custom board related to SD card is that - on custom board it is booting from mmc0 and on development board it is booting from mmc 1.

We have changed the fstab.freescale  for our custom board to mount the partitions of mmc0.

fstab.freescale of our board is attached below.

 

As the /data and /cache partition fails to get mounted, the android boot up does not go any further.

 

Please help to identify and resolve the issue. Any immediate help would be highly appreciated.

Original Attachment has been moved to: fstab.freescale.zip

Outcomes