AnsweredAssumed Answered

production hab type for imx25

Question asked by Erhan Yigitbasi on Apr 28, 2017
Latest reply on May 22, 2017 by Yuri Muhin

 

Everything is fine for secure boot when we are in engineering mode. So we decided to try production hab type. The device is booted successfully in production mode hab type.
After that we erased the flash of the device in order to test another signed u-boot image.
The device now starts in programming mode and we want to flash something with mfg tool but it does not boot the mfg firmware.
The device waits forever in the memory initialization section. What shoud we use to initialize the device to boot from memory in order to reprogram?
Logs:
 
Friday, April 28, 2017 17:13:43
1 - Panel A Start processing TEST<LIST/>.
Panel A Start <CMD/> type="find" body="BootStrap" file="" timeout="60" onError="" text="".
1 - Panel A Finished <CMD/> type="find" body="BootStrap" file="" timeout="60" onError="" text="" SUCCESS code=0x0.
Panel A Start <CMD/> type="init" body="Memory" file="mx25ddr2.xml" timeout="10" onError="" text="".
Panel A: Reason is unknown,Operation stopped by user. The process terminated unexpectedly.
UCL.xml file
    <CMD type="find" body="BootStrap" timeout="60"/>
    <CMD type="init" body="Memory" file ="mx25ddr2.xml" />
    <CMD type="load" file="uImage" address="0x80100000" loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Doing preLoad."</CMD>
    <CMD type="load" file="initramfs.cpio.gz.uboot" address="0x80800000" loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Doing preLoad."</CMD>                                
    <CMD type="load" file="u-boot-signed.bin" address="0x83F00000" loadSection="OTH" setSection="APP" HasFlashHeader="TRUE" >Loading OS image.</CMD>
We also tried this but it again waits for ever in the first line:
 
<CMD type="boot" body="BootStrap" file ="u-boot-signed.bin" >Read from DDR script from U-Boot to init DDR Memory.</CMD> 
    <CMD type="load" file="uImage" address="0x80100000" loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Doing preLoad."</CMD>
    <CMD type="load" file="initramfs.cpio.gz.uboot" address="0x80800000" loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" >Doing preLoad."</CMD>                                

Outcomes