AnsweredAssumed Answered

MCUXpresso IDE on Ubuntu 17.04

Question asked by safarmer on Apr 24, 2017
Latest reply on Sep 26, 2017 by Neil Hancock

Hi,

 

I had installed MCUXpresso 10.0.0 build 344 on Ubuntu 16.04 and my LPCLink2 probe was working fine. I have found that after upgrading to Ubuntu 17.04 that the probes can no longer be found and debugging fails. I have also tried with an LPC11u68 xpresso v2 board with the same result. The system is able to both probes, but ProbeList returns no probes.

 

$ dmesg

[ 133.076818] usb 1-1: new high-speed USB device number 7 using xhci_hcd
[ 133.217912] usb 1-1: New USB device found, idVendor=1fc9, idProduct=000c
[ 133.217916] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 133.217919] usb 1-1: Product: LPC
[ 133.217921] usb 1-1: Manufacturer: NXP
[ 133.217923] usb 1-1: SerialNumber: ABCD

 

$ lsusb

Bus 001 Device 007: ID 1fc9:000c NXP Semiconductors

 

redlink> ProbeList

No probes found


Has anyone managed to get the probe working under Ubuntu 17.04? 

 

Cheers,

- Shane

Outcomes