AnsweredAssumed Answered

imx6ul EVK + Murata 1DX - WiFi failure while scanning with bluetooth

Question asked by Nik Markovic on Apr 19, 2017
Latest reply on Apr 19, 2017 by igorpadykov

I am using the EVK board with Murata 1DX module and doing the following:

  • Using the downloaded SD card from NXP site
  • setenv fdt_file imx6ul-14x14-evk-btwifi.dtb in u-boot
  • Using gpio export on GPIO 508 in sysfs in combination with hciattach "/dev/ttymxc1" "bcm43xx" "3000000" "flow" to bring up bluetooth
  • Using sysfs to modify bcmdhd firmware and nvram path and wpa_supplicant to bring up wifi

I am able to bring up bluetooth and wifi. Bluetooth and wifi performance is perfect while both are not in use. However, while scanning with bluetooth using the provided BlueZ stack or "hcitool lescan", pings start fluctuating and going up to 2+ seconds and experience packet loss, eventually reaching 50 seconds if left long enough and losing wifi connectivity with eventual "Link down Reason : WLC_E_DEAUTH". Ifconfig reports no TX/RX errors. The wifi connection is pretty much unusable during bluetooth scan.

 

Some oddities and things we've tried

  • The address of both Murata EVK modules that we have, and all our custom boards have the same BT address 43:43:A1:12:1F:AC. The custom boards have "engineering sample chips", but I suspect that they wouldn't have programmed in BD Addressees on these EVK retail modules or even engineering samples. That makes me think that we're not using a correct firmware even though hciattach reports loading /etc/firmware/BCM43430A1.1DX.hcd successfully.
  • We also have a custom board and image built with yocto build, for which I followed instructions (hopefully correctly) from Murata's linux docs to put the firmware on the image. The problem is that those docs refer to the 3.x kernel, so I had trouble correlating it to 4.1 and I'm unsure if it is done correctly. Could use some latest instructions.
  • I tried using brcmfmac driver instead of bcmdhd, but the driver is silent no matter what I try. I can't find an example on how to get the WL_REG_ON (TAMPER-5 GPIO) working with the MMC probe in the device tree to trigger the brcmfmac driver. Any ideas on how to try this driver would be appreciated.

Any thoughts on what we could be doing wrong?

Thanks,

Nik

Outcomes