AnsweredAssumed Answered

Currently unable to debug on MPC5777C-416DS

Question asked by Ingo Giersch on Apr 11, 2017
Latest reply on Apr 11, 2017 by Peter Vlna

Hi,

I have a 'MPC5777C-416DS' mounted on an SPC57xxMB.

I have connected a Lauterbach Power Debug Interface USB 3 with an LA-7763 DEBUG-MPC5500 to the 14 pin JTAG connector on the MPC5777C-416DS.

 

When I switch power on the Power LEDs on mainboard and daughterboard light up green.

Sadly also the reset LED D8 continuously signals reset by shining red the whole time.

Pressing the reset button SW2 lights the orange LED D10, but D8 never stops shining red.

 

When I try the CMM script ' D:\Debugger\T32_PA_201605\demo\powerpc\flash\mpc5777c.cmm' Trace 32 reports 'Debug port fail' at System.detect.cpu.

 

I even tried to connect with 'Halt core at power-on reset' which detects switching off and on, but after that it reports an error.

 

Is there anything else I could do/configure to activate debugging via JTAG?

I tried to switch the JTAG voltage via J32 from default 3.3V to 5V, but that didn't change anything.

 

Any suggestions are very much appreciated.

Outcomes