AnsweredAssumed Answered

Invalid module format while loading driver in imx6

Question asked by chandra sekhar on Apr 10, 2017
Latest reply on Apr 13, 2017 by chandra sekhar

I am trying to load module through modprobe. I am getting below error

root@imx6ulevk:/lib/modules/3.14.38-6UL_ga+ge4944a5/kernel/drivers/usb/gadget# modprobe libcomposite
libcomposite: version magic '3.14.38-6UL_ga+ge4944a5 SMP preempt mod_unload modversions ARMv7 p2v8 ' should be '3.14.38-6UL_ga+ge4944a5 preempt mod_unload ARMv7 p2v8 '
modprobe: can't load module libcomposite (kernel/drivers/usb/gadget/libcomposite.ko): invalid module format

 

below is the output of uname -r 

root@imx6ulevk:/lib/modules/3.14.38-6UL_ga+ge4944a5/kernel/drivers/usb/gadget# uname -r
3.14.38-6UL_ga+ge4944a5

 

why is the error coming and can anyone give a solution for this 

Outcomes