AnsweredAssumed Answered

trouble booting linux kernel for imx6ull

Question asked by haithem smida on Apr 5, 2017
Latest reply on Apr 20, 2017 by Kane Jiang

Hello every body,

I just started integration of an im6uLL board, trying some test with an evk board.

I'd like to compile a linux kernel and use it, but the kernel doesn't boot and freeze

 

here is the detail of what i tried:

downloading kernel source from: linux-imx.git - i.MX Linux Kernel (4.1.15_2.0.0 GA)

create a sid chroot

use the sid chroot and add architecture armhf

installing arm-toolchain  arm-linux-gnueabihf

export ARCH=arm

export CROSS_COMPILE=arm-linux-gnueabihf-

make menuconfig , and activate imx6ull support 

 

make 

copy the new zImage and imx6ull-14x14-evk.dtb  on the microSD

fatload mmc 1:1 0x83000000  imx6ull-14x14-evk.dtb

fatload mmc 1:1 0x80800000 zImage

bootz 0x80800000 - 0x83000000

After calling  bootz, and entring  kernel_entry(0, machid, r2); in boot_jump_linux , 

the linux kernel freeze  with no debug trace.

 

 

i tried also the use the predefined config  : imx_v6_v7_defconfig

make imx_v6_v7_defconfig

make 

but I get compilation error :undefined reference to `mxc_dispdrv_gethandle'

seems strange the support of this board !

could any one please help me figure out what's going on.

Outcomes