AnsweredAssumed Answered

LPC1788 & NXP-emWin538-libraries, compile error

Question asked by my z on Apr 2, 2017
Latest reply on Apr 7, 2017 by my z
Hello , All:
        I am used LPC1788 & emwin5.30c in my new product .But I find a bug in emwin5.30c, so I want update emwin to 5.38 version. My compiler is keil mdk 5.23,  I download NXP-emWin538-libraries.zip and replace emwin5.30c in my project .The compile Error like this:
.\Objects\DispPrj.axf: Error: L6366E: WM_ValidateWindow.o attributes are not compatible with the provided attributes .
Object WM_ValidateWindow.o contains Build Attributes that are incompatible with the provided attributes.
    Tag_CPU_arch = ARM v7E-M (=13)
.\Objects\DispPrj.axf: Error: L6366E: WM__ForEachDesc.o attributes are not compatible with the provided attributes .
Object WM__ForEachDesc.o contains Build Attributes that are incompatible with the provided attributes.
    Tag_CPU_arch = ARM v7E-M (=13)
        Error nums up to 239. I don't know what occurred , and how can I sovle these errors?
        Thanks and wait for help.

Outcomes