AnsweredAssumed Answered

Has SDK 2.0 been tested on LS1043ARDB

Question asked by stacym on Mar 29, 2017
Latest reply on Mar 29, 2017 by stacym

Hello all,

 

I believe I posted this question to the wrong forum yesterday.  My application is being tested on LS1043ARDB until custom HW is ready.  I had a working build that used SDK 0.5 and Kernel 3.19.  I

could build and boot and run my custom processes on the RDB

 

I decided to switch to new SDK (2.0) which included Kernel upgrade to 4.1.  I used the DTS files from the source (fsl-1043a-rdb.dts and .dtsi)  This build freezes/hangs at Starting kernel...

 

Since I had SDK 0.5 and Kernel 3.19 working on the same board, I tried using the DTB file from that build with the new SDK.  Doing that, the board boots up to a login prompt but there are several errors around the Ethernet devices and RTC.  Looking back at the boot messages, the following problems occur during boot:

[    0.502038] fsl-fman 1a00000.fman: ReadFmDevTreeNode: Failed to get FM clock structure

[    0.509955] fsl-fman: probe of 1a00000.fman failed with error -5

[    0.516022] Freescale FM module, FMD API version 21.1.0

[    0.521292] fsl-fman-port: probe of 1a82000.port failed with error -5

[    0.527732] fsl-fman-port: probe of 1a83000.port failed with error -5

[    0.534179] fsl-fman-port: probe of 1a84000.port failed with error -5

[    0.540624] fsl-fman-port: probe of 1a85000.port failed with error -5

[    0.547064] fsl-fman-port: probe of 1a86000.port failed with error -5

[    0.553509] fsl-fman-port: probe of 1a87000.port failed with error -5

[    0.559968] fsl-fman-port: probe of 1a88000.port failed with error -5

[    0.566409] fsl-fman-port: probe of 1aa8000.port failed with error -5

[    0.572858] fsl-fman-port: probe of 1a89000.port failed with error -5

[    0.579304] fsl-fman-port: probe of 1aa9000.port failed with error -5

[    0.585747] fsl-fman-port: probe of 1a8a000.port failed with error -5

[    0.592192] fsl-fman-port: probe of 1aaa000.port failed with error -5

[    0.598641] fsl-fman-port: probe of 1a8b000.port failed with error -5

[    0.605081] fsl-fman-port: probe of 1aab000.port failed with error -5

[    0.611530] fsl-fman-port: probe of 1a8c000.port failed with error -5

[    0.617970] fsl-fman-port: probe of 1aac000.port failed with error -5

[    0.624418] fsl-fman-port: probe of 1a8d000.port failed with error -5

[    0.630864] fsl-fman-port: probe of 1aad000.port failed with error -5

[    0.637307] fsl-fman-port: probe of 1a90000.port failed with error -5

[    0.643753] fsl-fman-port: probe of 1ab0000.port failed with error -5

[    0.650284] Freescale FM Ports module

[    0.653936] fsl_mac: fsl_mac: FSL FMan MAC API based driver

[    0.659559] fsl_mac 1ae0000.ethernet: fm_bind(/fman@1a00000) failed

[    0.665833] fsl_mac 1ae2000.ethernet: fm_bind(/fman@1a00000) failed

[    0.672110] fsl_mac 1ae4000.ethernet: fm_bind(/fman@1a00000) failed

[    0.678382] fsl_mac 1ae6000.ethernet: fm_bind(/fman@1a00000) failed

[    0.684659] fsl_mac 1ae8000.ethernet: fm_bind(/fman@1a00000) failed

[    0.690935] fsl_mac 1aea000.ethernet: fm_bind(/fman@1a00000) failed

[    0.697207] fsl_mac 1af0000.ethernet: fm_bind(/fman@1a00000) failed

[    0.703542] fsl_dpa: FSL DPAA Ethernet driver

[    0.708009] fsl_dpa fsl,dpaa:ethernet@0: dev_get_drvdata(1ae0000.ethernet) failed

[    0.715493] fsl_dpa: probe of fsl,dpaa:ethernet@0 failed with error -22

[    0.722125] fsl_dpa fsl,dpaa:ethernet@1: dev_get_drvdata(1ae2000.ethernet) failed

[    0.729605] fsl_dpa: probe of fsl,dpaa:ethernet@1 failed with error -22

[    0.736231] fsl_dpa fsl,dpaa:ethernet@2: dev_get_drvdata(1ae4000.ethernet) failed

[    0.743711] fsl_dpa: probe of fsl,dpaa:ethernet@2 failed with error -22

[    0.750343] fsl_dpa fsl,dpaa:ethernet@3: dev_get_drvdata(1ae6000.ethernet) failed

[    0.757817] fsl_dpa: probe of fsl,dpaa:ethernet@3 failed with error -22

[    0.764450] fsl_dpa fsl,dpaa:ethernet@4: dev_get_drvdata(1ae8000.ethernet) failed

[    0.771930] fsl_dpa: probe of fsl,dpaa:ethernet@4 failed with error -22

[    0.778558] fsl_dpa fsl,dpaa:ethernet@5: dev_get_drvdata(1aea000.ethernet) failed

[    0.786037] fsl_dpa: probe of fsl,dpaa:ethernet@5 failed with error -22

[    0.792670] fsl_dpa fsl,dpaa:ethernet@8: dev_get_drvdata(1af0000.ethernet) failed

[    0.800150] fsl_dpa: probe of fsl,dpaa:ethernet@8 failed with error -22

...

...

hwclock: can't open '/dev/misc/rtc': No such file or directory

date: invalid date '0310014735201703'

hwclock: can't open '/dev/misc/rtc': No such file or directory

Running postinst /etc/rpm-postinsts/100-sysvinit-inittab...

Running postinst /etc/rpm-postinsts/101-inetutils-inetd...

Running postinst /etc/rpm-postinsts/102-inetutils-ftpd...

INIT: Entering runlevel: 5un-postinsts exists during rc.d purge

Configuring network interfaces... ifup: can't open '/etc/network/interfaces': No such file or directory

Starting OpenBSD Secure Shell server: sshd

  generating ssh RSA key...

  generating ssh ECDSA key...

  generating ssh DSA key...

  generating ssh ED25519 key...

Privilege separation user sshd does not exist

hwclock: can't open '/dev/misc/rtc': No such file or directory

Starting network benchmark server: netserver.

Starting system log daemon...0

 

I am wondering if the 2.0 SDK was tested on this dev board?

 

Thanks, Stacy

Outcomes