AnsweredAssumed Answered

Watchdog not enabled on startup

Question asked by Josiah Carlisle on Mar 21, 2017
Latest reply on Mar 23, 2017 by Josiah Carlisle

I have a program that uses Processor Expert and it appears as if the watchdog is not functioning.  I have added a WatchDog component to my project, but have disabled auto initialization.  I have also gone into the 'Cpu:SKEAZN...' processor component and set 'Watchdog disable' to 'no'.  My assumption is that this should leave the watchdog registers as their default values (which should be enabled, and set to some reset time), since the Watchdog component never initializes itself.  However, when I run the program, it is not resetting on watchdog timeout.  Clearly I am not understanding something here; what am I missing?

 

-Josiah

Outcomes