AnsweredAssumed Answered

FRDM-KV10Z Can't program (Stalling); MBED Volume 32k free space

Question asked by Jeffrey Chan on Mar 21, 2017
Latest reply on Mar 24, 2017 by Jeffrey Chan

Is this normal?

Filesystem      Size   Used  Avail Capacity   iused     ifree %iused  Mounted on

/dev/disk4      48Ki   16Ki   32Ki    34%        32         0  100%   /Volumes/MBED

 

I tried to load hello_world.bin from the SDK but I got some errors:

cp: hello_world.bin: could not copy extended attributes to /Volumes/MBED/hello_world.bin: Device not configured

 

I then tried PyOCD but then I got this:

$ pyocd-flashtool -u
INFO:root:DAP SWD MODE initialised
WARNING:root:KV10Z7 in secure state: will try to unlock via mass erase

 

When that failed, I tried upgrade OpenSDA but now there's not enough free space to upload anything at all (even in bootloader mode).  The Segger OpenSDA bin files are well over 32k.

 

Trying to copy a smaller item results in a never finishing copy:

$ cp k20dx128_bootloader_0x8000.bin /Volumes/MBED #stalls "forever"

 

And now trying to replace the demo app (in non-bootloader)

$ cp ecompass.bin  /Volumes/MBED/ # stalls forever

 

Perhaps there's something I'm missing?

 

Did my KV10Z somehow get locked and that's why I can't write a new program?

 

Is my bootloader working properly?  Is it showing up as the MBED volume proof enough that my bootloader isn't bricked?  If bootloader is okay, why does updating the bootloader (in bootload update mode; reset pin down on power-up) stall on copy?

Outcomes