AnsweredAssumed Answered

Cannot flash FRDM-KW41Z

Question asked by Reg Webb on Mar 11, 2017
Latest reply on Jun 8, 2017 by Jurie Timothée

When trying to add a new program, connectivity test as shown in the video getting started, I receive the following error and cannot figure out why.  I have tried updating Segger with 24_OpenSDA_FRDM-KW41Z but except for the fact that the board that I tried that on now just shows a red LED glowing at J24 I have the same error.  Did connect terminals to reset OpenSDA position.

Before using the KW41Z board I did some experimenting with the FRDM-KL03Z board since new to ARM and that worked out perfectly ok.

 

SEGGER J-Link GDB Server V5.10n Command Line Version

 

JLinkARM.dll V5.10n (DLL compiled Feb 19 2016 18:41:43)

 

-----GDB Server start settings-----

GDBInit file:                  none

GDB Server Listening port:     2331

SWO raw output listening port: 2332

Terminal I/O port:             2333

Accept remote connection:      localhost only

Generate logfile:              off

Verify download:               on

Init regs on start:            on

Silent mode:                   off

Single run mode:               on

Target connection timeout:     0 ms

------J-Link related settings------

J-Link Host interface:         USB

J-Link script:                 none

J-Link settings file:          none

------Target related settings------

Target device:                 MKW41Z512xxx4

Target interface:              SWD

Target interface speed:        30kHz

Target endian:                 little

 

Connecting to J-Link...

J-Link is connected.

Failed to set device (MKW41Z512xxx4). Unknown device selected?ERROR : Failed to set device.

 

Firmware: J-Link OpenSDA 2 compiled May  6 2016 11:04:17

Hardware: V1.00

S/N: 621000000

Checking target voltage...

Target voltage: 3.30 V

Listening on TCP/IP port 2331

Connecting to target...ERROR: No CPU core or target device has been selected. Please make sure at least the core J-Link shall connect to, is selected.

ERROR: Could not connect to target.

Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...

Shutting down...

Outcomes