AnsweredAssumed Answered

QN9020 MiniDK - How to load and debug (Keil)

Question asked by Mickael Renault on Mar 10, 2017
Latest reply on Mar 22, 2017 by Mickael Renault

Hi,

 

We just bought a QN9020 MiniDK board to work on the BLE capability. We use the Keil IDE to develop our code, but we are not able to load and debug the board. For now we have to load our program through the QBlue software provided by NXP, but we expect to use the usual debugger as soon as possible.

 

Here is our process:
- We soldered R37 and R38 to use the debugger (as per the documentation UM10895, p.7)
- We shorted R35 and R36 to use the debugger (as per the documentation UM10895, p.8)
- We have the JLink Driver correctly set up, and the QN9020 board configuration correctly imported from QBlue into Keil
- We want to load and debug the QPP example via Keil
-> We have an error, which is not exactly the one mentioned in AN11664, p.16 (5.1.2: Download file in Keil). We tried using RESET button, or button1 or button2, but we always have the same error.

 

Attached is a home-made video to illustrate (sorry, not professional quality!)
Or follow this link: http://www.mireweb.com/DebugQN9020.mp4

 

Did you find out the problem here? Please feel free to share!

If not, what is your best method to debug this board?


Thanks for your help!

 

Mickael

Attachments

Outcomes