Raimond Dragomir

USBDM software problems with Kinetis E targets

Discussion created by Raimond Dragomir on Mar 5, 2017
Latest reply on Apr 18, 2017 by pgo

I'm using USBDM only for Kinetis E targets. I started with KE02Z microcontrollers and was using .120 version for quite a while. Recently I started using the more advanced KE1xF familiy (cortex-m4) and installed .150 and then .160 just to see if there is support for it (unfortunately... not... yet).

 

The thing is that when I came back to my KE02Z devices nothing worked reliable. In fact the only thing working seems to be mass erase... I downgraded back to .150 - no luck. I downgraded again to .120 - Voila!

 

So the .120 works just fine with KE02Z devices, the 150/160 seems not.

 

I'm using a JS16 based dongle. Not tried with an OpenSDA one. For my KE1xF devices I'm using indeed a FRDM board for KE1xZ (because they have the same support for 5V devices like the TWR18F boards) and an opensda version for segger j-link  It's just a shame that the open source opensda firmware for these devices is not yet functional

 

I hope I will see KE1xF support for USBDM soon!

 

Also, a very interesting feature would be a possibility to partition the FlexNVM system for using as eeprom. The chips come with the FlexNVM factory default as all dataflash, and if you really  want to use it as eeprom you need to run first a small application which configures it as such. Besides developing such an application, this implies another step in production programming.

 

Best regards,

Raimond

Outcomes