AnsweredAssumed Answered

Capturing camera frame via user space

Question asked by Alexandre Chartrand on Mar 3, 2017
Latest reply on Nov 3, 2017 by Mustafa Bakırcıoglu

Hi,

 

We car currently trying to integrate an unsupported camera (IMX278) to our custom board built with an IMX6D. The camera uses 4 lanes CSI connection. We use linux kernel 3.14.

 

What we have done right now is initializing the camera via I2C and generating the pixel clock in user space and everything seems to work fine. Then, I try the unit test mxc_v4l2_capture.out and when I run it I get the following error:

 

Unable to open /dev/video0
Unable to create y frame recording file

 

If I run : dmesg | grep v4l

 

I got this output:

ERROR: v4l2 capture: slave not found!

 

I have seen that the mxc_v4l2_capture driver only supports some specific cameras. So, here's my questions:

 

What do I have to modify in the unit test or in the mxc_v4l2 driver to add support for my camera?

 

Is it possible to do everything in user space or do I need to write a driver?

 

Is there another way to get the camera frame from user space?

 

Thank you,

 

Alexandre

Outcomes