AnsweredAssumed Answered

We meet a strange issue when programming nor flash of LS1023A with codewarrior

Question asked by LINDA LIU on Mar 1, 2017
Latest reply on Mar 2, 2017 by Adrian Stoica

for our boards in which LS1023A is used,  we use nor flash as boot sourec (cfg_rcw_src[0:8] is 0x25). we did pre-programming RCW with nor flash in manufacture. When we received the boards its ok we can use codewarrior to connect our board then program u-boot succesfully

 

However during bring up,  several boards are wrongly programmed so that the RCW is probably destroyed. We have to change the hardware strap pins to 0x9E which is hard-coded mode (both SYSCLK and DDRCLK in our design is 100MHz), but under this case when we triy to re-program RCW, it alway says:

 

 

fl_current nor

fl_unprotect 0x100000 0x87c67

Unprotecting....

Error: Protocol error with Rcmd

FP: id verify fail

 

I have tried program/erase/blank check the same issue. Please see the figure below.

 

Could you help me check why? How can we fixed it?

Outcomes