AnsweredAssumed Answered

bitbake stuck on using the imx6qsabresd MACHINE

Question asked by Joseph Kissell on Feb 26, 2017
Latest reply on Mar 3, 2017 by Carlos_Musich

Hello,

Embedded linux newbie here. I'm trying to come up to speed on a i.mx28 development which is already in progress. The previous developers are not available to help me out. So, I'm spending a LOT of time googling my way through this task.

 

I've downloaded fsl-community-bsp-platform ( Yocto > Poky > Dora branch), initialized, and sync'd the repo.

Next, I copied our customer's meta layer into the sources folder and updated the bblayers.conf file to point to that new meta layer.

 

Then, I run "source ./setup-environment" to get a list of machines available. I see my added machine type and attempt use it with this command: "MACHINE=<customer machine> source ./setup-environment build"

 

That takes me into the build folder where I then run "bitbake core-image-base". That starts building an image, but I notice that it says MACHINE = "imx6qsabresd", which is the default machine. 

 

Can someone please explain why the <customer machine> didn't take?

 

Note: I've also tried updating the default Machine in setup-environment to be <customer machine>, but looks like it keeps getting reset back to "imx6qsabresd" each time I run the setup-environment script.

Outcomes