AnsweredAssumed Answered

ethernet connection not stable

Question asked by longqi luo on Feb 23, 2017

hello, I use P1023 to design ethernet based on RGMII largely refered to P1023rds schemetic. The phy aslo is AR8035, and now status as: 
EC__GTX_CLK125 125M from PHY
TSEC1_RX_CLK 25M continuously from phy
TSEC1_GTX_CLK 25M  only when transmission is going

RXD[3:0] have signal continuously even no ping command(why

TXD[3:0] have signal only during ping
but the connection is not stable, see below log:

 => ping 192.168.1.20
Using FM1@DTSEC1 device
ping failed; host 192.168.1.20 is not alive
=> ping 192.168.1.20
Using FM1@DTSEC1 device
host 192.168.1.20 is alive
=> ping 192.168.1.20
Using FM1@DTSEC1 device
host 192.168.1.20 is alive
=> ping 192.168.1.20
Using FM1@DTSEC1 device
ping failed; host 192.168.1.20 is not alive
host 192.168.1.20 is alive
=> ping 192.168.1.20
Using FM1@DTSEC1 device
host 192.168.1.20 is alive
=> tftp
Using FM1@DTSEC1 device
TFTP from server 192.168.1.20; our IP address is 192.168.1.19
Filename 'uImage'.
Load address: 0x800000
Loading: T T T T T T T #T T T 
Retry count exceeded; starting again
Using FM1@DTSEC2 device
TFTP from server 192.168.1.20; our IP address is 192.168.1.19
Filename 'uImage'.
Load address: 0x800000
Loading: *
Abort
=> 
I test some signals, the eth reset  and data EN is right .Could some one give me some advices about how should i find the problem out?attached is my schemetic, thank you!

Original Attachment has been moved to: schemetics.rar

Outcomes