AnsweredAssumed Answered

imx6dl - ddr3 issues.

Question asked by Theo Debrouwere on Feb 23, 2017

Hi,

 

I have a custom design with a imx6dl, combined with 4 * 2Gbit DDR3 ram

Samsung K4B2G1646F-BCK0, running as DDR3-800.

Spec: http://www.samsung.com/semiconductor/global/file/product/2016/03/DS_K4B2G1646F-BY-M_Rev10-1.pdf 

 

I generated timings

* using the I.MX6DQSDL DDR3 Script Aid V0.10 document

* reading data sheets & calculating the register contents (attached)

 

I've been trying to obtain additional settings with the DDR_Tester application. (ddr_stress_tester_v2.60)

 

However, the tool always ends with the following issue.

Starting DQS gating calibration

*** snip ***
ERROR FOUND, we can't get suitable value !!!!
dram test fails for all values.

Error: failed during ddr calibration

 

It seems that the first part (Write level HW calibration) runs fine.

 

I've search the forum, and I noticed that there are others with similar problems.

I've tried several things (like increasing WALAT), but without any results.

I also tried several boards, all of them have the same problem.

 

Any idea what could be wrong? Is one of my settings wrong? Hardware failure?

Anything that I can try next?

Original Attachment has been moved to: ddr3.txt.zip

Original Attachment has been moved to: MX6DL_samsung_ddr3.inc.zip

Outcomes