Daniel Watson

Ubuntu 16.04 LTS Yocto build issue fix

Discussion created by Daniel Watson Employee on Feb 21, 2017

For the people who are wanting to build a Yocto image of the NXP Modular Gateway using Ubuntu 16.04, there is some changes needed:

 

Due to Ubuntu 16.04 not natively having libsdl, some changes to the conf/local.conf needs to be made to tell bitbake that qeum needs to be sources and compiled.

 

To do this, comment out/remove the following lines in conf/local.conf in your build folder: 

PACKAGECONFIG_append_pn-qemu-native = " sdl"

PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"

ASSUME_PROVIDED += "libsdl-native"

Outcomes