yintai shao

T2080QDS is broken by a software iamge

Discussion created by yintai shao on Feb 19, 2017

We have two T2080QDS targets which are broken suddenly when booting a VxWorks image. The two boards are brought with same batch number.

 

At first, the image is couldn’t be boot up on the board,  it is hung when MMU is enabled. After I re-power on it, the u-boot is works well. (This testing image could works well on all others previous T2080QDS boards.) I tried to find whether is it a software bug in this image, after I tried to boot the image several times, the board was hanged during the boot process after the MMU is enabled just like in the previous trying, the CPU fan and ATX power fan were all stop at same time. Then I re-powered on the board, the u-boot was never start. The luminous diodes D27, D35 and D36 are all light, ATX power fan and CPU fan just run and then stopped quickly. Our VxWorks image is works well on other our previous brought T2080QDS board. During the last boot process, all the operations is normal, without any hand touching.  I can’t understood why a software image could lead to such hardware broken.

 

I have verified that the NOR flash on the broken board is not damaged, it could works well on other T2080QDS board.

 

The version number of the broken T2080QDS are:

                SCH:       SCH-28012 REVA A4

                S/N:       K1530 34861 -005

                70028102 REV A

 

Is some differences between the previous and the broken boards?

 

The VxWorks image and DTB file are attached. The u-boot boot commands are:

 

->tftp 20000000 uVxWorks;tftp 30000000 t2080qds.dtb;bootm 20000000 – 30000000

 

Thank you very much! Hope to get your help.

 

Thanks

Yintai Shao

Original Attachment has been moved to: uVxWorks.zip

Original Attachment has been moved to: t2080qds.dtb.zip

Outcomes