AnsweredAssumed Answered

USB Host using USB Stack v5.0 of FRDM-K64F

Question asked by Jakub Pankau on Feb 16, 2017
Latest reply on Feb 23, 2017 by Jakub Pankau

I'm trying to get the example from USB stack for USB Host Mass Storage Device to work on the FRDM-K64F board in Keil. I tried following the instructions and created a multi project workspace which includes:

   - usbh_bm_frdmk64f

   - host_msd_cmd_frdmk64f

As per instruction, first I complied the first project and then the second. Both of them compile without errors and I can download it to the eval board. I am using the CMSIS-DAP as a debugger for FRDM-K64F. Once I run the code it stops in the HardFault_Handler. The system gets the fault in the Reset Handler right after it starts and the fault flag that is set is the NOCP - "No coprocessor Usage Fault".

I also tried running another example for a Device CDC and the same error is happening. The Target options are set for the correct microcontroller and I even tried running different scatter file (from a project that works) but the same error is happening.

Is there anything that needs to be changed in code or setting?

Also has anyone got it to work? v5.0?

 

Also is there any other drivers/applications to use for usb? I need host for MSD and device for CDC.

 

Any help is appreciated.

Outcomes