AnsweredAssumed Answered

imx6q sabresd board xserver is crashing .I am using the xserver vivante driver.

Question asked by SHIV KUMAR AGARWAL on Feb 13, 2017

i am using imx6q  sabresd board my xserver is crashing when i am using glxinfo or glxgears but when i am issuing the es2gears -info .its showing the correct behaviour.root@linaro-alip:/home/linaro/Xorg_bin/working_Xorg# glxgears -info
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
GL_RENDERER   =
GL_VERSION    =
GL_VENDOR     =
GL_EXTENSIONS =
(EE)
(EE) Backtrace:
(EE)
(EE) Segmentation fault at address 0x3f8
(EE)
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE)
(EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 37 requests (37 known processed) with 0 events remaining.
Perform final cleanup before process termination!
xinit: connection to X server lost
[1]+  Done                    startx  (wd: /home/linaro/Xorg_bin/test_Xorg)
(wd now: /home/linaro/Xorg_bin/working_Xorg)
================================================================
but es2gears -info is passing
root@linaro-alip:/home/linaro/Xorg_bin/working_Xorg# es2gears -info
EGL_VERSION = 1.4
EGL_VENDOR = Vivante Corporation
EGL_EXTENSIONS = EGL_KHR_reusable_sync EGL_KHR_fence_sync EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_lock_surface EGL_KHR_create_context EGL_KHR_surfaceless_context EGL_EXT_create_context_robustness EGL_EXT_buffer_age EGL_EXT_protected_surface EXT_image_dma_buf_import
EGL_CLIENT_APIS = OpenGL_ES OpenVG
EGLUT: failed to get an visual of id 0x0
=======================================================================

Here are my attached Xorg logs

Original Attachment has been moved to: Xorg.0.log.zip

Outcomes