AnsweredAssumed Answered

arm-poky-linux-gnueabi-ld: unrecognized option '-Wl,-O1'

Question asked by 钊 黄 on Feb 9, 2017
Latest reply on Feb 10, 2017 by 钊 黄

I have installed the cross-toolchain by execute this shell 'fsl-imx-fb-glibc-x86_64-fsl-image-gui-cortexa7hf-neon-toolchain-4.1.15-2.0.0.sh'. I want to cross compile a source code, but an ERROR occur as below:

 

huangzhao@huangzhao-virtual-machine:~/swupdate$ make
LD core/built-in.o
arm-poky-linux-gnueabi-ld: unrecognized option '-Wl,-O1'
arm-poky-linux-gnueabi-ld: use the --help option for usage information
make[1]: *** [core/built-in.o] ERROR 1
make: *** [core] ERROR 2

 

Can you help me to solve this problem? Thanks.

Outcomes