AnsweredAssumed Answered

how to avoid green screen at beginning of rtsp streaming playback

Question asked by huang zhanfei on Feb 5, 2017
Latest reply on Feb 15, 2017 by huang zhanfei

hi all , 

 

i am playing rtsp streaming with gstream-0.1 on imx53, the rtsp server is non-stop sending rtp packages,  i play this stream  with this one:

 

gst-launch  rtspsrc location=rtsp://192.168.1.123:554/vga name=source ! queue  max-size-buffers=0 max-size-time=0 ! rtph264depay ! mfw_vpudecoder ! mfw_v4lsink source. ! queue max-size-buffers=0 max-size-time=0  !  rtpmpadepay ! mpegaudioparse ! mad ! alsasink 


this works very well except that there are some time green screen about 1~3 seconds at the beginning of the playback,  i searched about what problem of this, and some one said playback should wait for an i-frame (keyframe) before playing, 

i don't know where to set this parameter or (maybe ) adding extra element bin (caps) ? or any other solutions is welcome !

 

 

Thanks!

Best Regards!

 

toot_hzf

Outcomes