AnsweredAssumed Answered

MQX v4.2 with VLE

Question asked by Ferenc Kovacs on Feb 3, 2017
Latest reply on Feb 22, 2018 by Burak Duzgun

Hi,
I work with an MPC5644A MCU, which has an e200z4 dual issue core.
Can I compile the MQX v4.2 to VLE instructions? According to the linked doc (http://www.nxp.com/assets/documents/data/en/supporting-information/FSL_MQX_4_0_2_RN.pdf ), MQX is ported to e200 VLE, so I think it should work, but it doesn't. When the execution reaches the _mqx() function, it jumps to the Interrupt section and stucks. The first intruction in the _mqx() function is se_stb r2,4(rsp).
Although I'm not sure, that the problem is about the VLE instructions...

 

Any help in this topic is appreciated!

 

Thank you!
János Murai

Outcomes