AnsweredAssumed Answered

Problem testing modifs in yocto

Question asked by Aaron Padilla on Feb 2, 2017
Latest reply on Feb 4, 2017 by jimmychan

Hi everybody,

 

I am facing a problem modifying and testing for remapping my debug uart, so I am modifying .config, device tree and u-boot include files, below the location of files modified:

 

/home/aaron/fsl-arm-yocto-bsp_2/build-x11/tmp/work/imx6dqscm_1gb_qwks-poky-linux-gnueabi/linux-imx/3.14.52-r0/build/.config

 

/home/aaron/fsl-arm-yocto-bsp_2/build-x11/tmp/work/imx6dqscm_1gb_qwks-poky-linux-gnueabi/u-boot-imx/2015.04-r0/git/include/configs/mx6dqscmqwks.h

 

/home/aaron/fsl-arm-yocto-bsp_2/build-x11/tmp/work-shared/imx6dqscm-1gb-qwks/kernel-source/arch/arm/boot/dts/imx6dqscm-1gb-qwks-rev2-fix-ldo.dts

 

Buy the problem is at compilation time, if I run a  bitbake image compilation like:

bitbake core-image-minimal or bitbake -f core-image-base

Nothing changes in the deploy folder, then if I run a forced clean compilation

bitbake -c clean core-image-base

bitbake -f core-image-base

the generated .sdcard file is updated but I think that my modifications are not compiled

 

If I modify something in the source/somelayer/conf... the bitbake image ovverrides my modifications

 

I have tried too with the fsl-image-qt5

 

So, what is the correct procedure to modify some things like uboot, device tree, kernel config in the build folder and then force a compilation without update the files from the source?

 

Thanks in advance,

Aaron

Outcomes