AnsweredAssumed Answered

FRDM-K66F bootloader and OpenSDA problem

Question asked by selman arslan on Feb 2, 2017
Latest reply on Feb 6, 2017 by Kerry Zhou

Hi all,

I received my FRDM -K66F board today and i plugged -in to PC with usb but i give a error. FRDM-K66F mbed serial&J-Link  that is the same problem J-Link dirver cant installed. Then i searched the forms and find different solutions. One of them is given inside the upside link. I tried that and device is working and PC is recognize the device by MBED device. then try to simple sample "hello world" example for K66F code compiled succesfully when try to send to device with OpenOCD debug( why OpenOCD because at nxp website given example done with that Debug) i took another error. localhost:3333: The system tried to join a drive to a directory on a joined drive. Failed to execute MI command  always given this error and cant sent to device.

 

Tried to different solutions about bootloader;

1-) Nxp websites give some bootloader file for FRDM-K66F. One of them for K66F other one default OpenSda v2.1. But none ofthem give solutions. When i drag&drop the *.bin file into the device with bootloader mode after the copy the file inside the device, windows 7 doesn't recognize the device and nothing happen.

 

2-) FRDM K66 OpenSDA  try to OpenSDA website and downloaded V2.1 and draged&dropped the device but another failure. Nothing happened and Windows does not recognize the device

 

Note:

Using KDS 3.2.0

Windows 7

FRDM-K66F

 

 

My board new and any secure pin active or not, i don't know?

And my reset LED(RED) always on why?

Outcomes