AnsweredAssumed Answered

Openssl Installation In Yocto Image and Configuration

Question asked by Devendra Singh Baghel on Feb 2, 2017
Latest reply on Feb 5, 2017 by Victor Linnik

Hi Everyone,

 

I want to connect with websites using "Secure HTTP" protocol for that I have installed openssl_1.0.2h in Yocto Image but I am unable to connect with google.com ( Note: I have tried to connect with different sites but here I am taking example of "google.com" ) using secure HTTP protocol (i.e. When I am trying to Run the following command "wget https://google.com", then I am getting Network is unreachable error.). Here is the log for command run:

 

root@imx6qsabresd:~# wget https://google.com
Connecting to google.com (216.58.196.110:443)
wget: error getting response: Network is unreachable

 

I am able to ping the google.com (i.e. Internet is available on board). Here is the log of ping command:

 

root@imx6qsabresd:~# ping google.com
PING google.com (216.58.196.110): 56 data bytes
64 bytes from 216.58.196.110: seq=0 ttl=56 time=8.656 ms
64 bytes from 216.58.196.110: seq=1 ttl=56 time=8.578 ms
64 bytes from 216.58.196.110: seq=2 ttl=56 time=8.704 ms
^C
--- google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 8.578/8.646/8.704 ms
root@imx6qsabresd:~#

 

And also I am able to connect with the google.com using insecure HTTP protocol (i.e. "wget http://google.com" is downloading its index.html ). Here is the log for the command run:

 

root@imx6qsabresd:~# wget http://google.com
Connecting to google.com (216.58.196.110:80)
Connecting to www.google.co.in (216.58.200.3:80)
index.html 100% |***********************************************************************************************************************| 12452 0:00:00 ETA
root@imx6qsabresd:~#

 

So why it is not connecting with URL's (i.e. webites) using "https"  protocol, is there any openssl configuration is required or any other dependencies package need to be installed.

Outcomes