AnsweredAssumed Answered

MfgTool Help - related to other posts

Question asked by Janet Estabridis on Jan 31, 2017
Latest reply on Feb 13, 2017 by Janet Estabridis

I'm using the NXP MCIMX6Q-SDB. I've been trying to use the V2.0.0 Manufacturing Tool. With the provided files to burn the eMMC with the uboot, kernel, dtb and rootfs.

The booting of the kernel hangs at: imx-wm8962 sound: snd_soc_register card failed (-517)

And the Tool says "No Device Connected"

 

I have also tried my kernel, dtb WHICH BOOTS FINE FROM THE SDCARD. and I get on the MfgTool_MultiPanel (Library: 2.7.0) "No Device Connected"

Starting UTP

uuc 0.5 [built Sep 16 2016 02:36:28]

And the kernel messages hang at UTP: Waiting for device to appear

 

I've looked at https://community.nxp.com/thread/325561 and https://community.nxp.com/thread/326184 and I have the same problems but haven't figured out a solution. Any help will be appreciated.

 

QUESTION: HOW TO CONFIGURE THE board to be in USB HOST mode? I'm assuming that it is a kernel setting. I've obtained my kernel by using the instructions - Freescale Yocto Project User's Guide and I built it as "core-image-base." Can I run "make menuconfig" locally now and modify the kernel?  

Is there something else I can read to figure out how to modify a kernel?

 

THANKS IN ADVANCE

Outcomes