AnsweredAssumed Answered

Program compiled on LPCXpresso v7 and does not compile on v8.2.2.

Question asked by Francois Aubet on Jan 25, 2017

Hello,

 

Like said in the title I changed computer and I cannot find the version 7 online so I downloaded the version 8.2.2. But my program does not compile anymore.

 

I get this errors:

- `M0CodeRam' overflowed by 248 bytes

- EDVSBoardOSM0.axf section `.data' will not fit in region `M0CodeRam'

- make: *** [EDVSBoardOS.axf] Error 1

- make: *** [EDVSBoardOSM0.axf] Error 1

- No slave code for _core_m0app

- undefined symbol `__vectors_start___core_m0app' referenced in expression

 

So I have two questions:

- Do you happen to know what change between this two versions that could lead to this errors? Then do you know how  to solve the problem?

 

- The other possibility, do you know where I can download the version 7? (I didn't find it but maybe it is still there, somewhere)

 

Thanks in advance!

Outcomes