AnsweredAssumed Answered

Linux-4.1.15 : problem with LAN8720A

Question asked by Aebischer Quentin on Jan 18, 2017
Latest reply on May 3, 2017 by Aebischer Quentin

Hello everyone,

 

I have an issue related to the LAN8720A ethernet phy and linux freescale kernel 4.1.15.

The problem is that the ethernet link never goes up.

 

I tried using a vanilla kernel (version 4.1.37 available on kernel.org), and it works with this version.

I used the same kernel configuration (imx_v6_v7_defconfig), as well as the same DTS file (at least the parts related to the ethernet configuration).

 

I then went ahead and copied all the source files in the drivers/net/ethernet/freescale directory from the 4.1.37 vanilla kernel to the 4.1.15 freescale kernel. It compiled OK, but it didn't change anything (ethernet link still doesn't go up).

 

I don't know how the network stack works in Linux, so I don't know what other parts of the kernel are involved in this bug.

Also I have read this thread from the NXP community :i.MX6UL ENET1 (with LAN8720A PHY) working in Uboot but not in Linux

But it didn't help

 

I'm open to every hint / suggestion

Thank you for reading me

 

Quentin

Outcomes