AnsweredAssumed Answered

Cannot use mfgtool2-cli on Linux

Question asked by Erez Amir on Jan 10, 2017
Latest reply on Oct 27, 2017 by Aaron Thompson

Hi,

I am trying to burn uboot and kernel to my QWKS-SCMIMX6 rev2 board.

I am using latest mfgtools downloaded from Quick Start Board for SCM-i.MX 6DQ|NXP 

Observations:

1. I do see the VID/PID of the board with lsusb

2. Tried every legal configuration of SW[2-3] - no influence

3. I've successfully loaded mfg uboot and kernel images with Windows 7 PC and MfgTool2.exe onto the same board and got linux console via serial port (I've got kernel panic at initrc, but thats another story)

 

The MfgToolLibLog.txt contains the following:

ModuleID[2] LevelID[1]: MxHidDevice::Read() Error reading from device 0x-7 with size 1025.

ModuleID[2] LevelID[1]: Failed to read HAB type from ROM!!!

ModuleID[2] LevelID[1]: Failed to initialize memory!

 

I suspect something wrong with mfgtoolcli and/or libMfgToolLib.so. Did someone successfully loaded mfg uboot and kernel using those mfgTools and linux host machine?

 

Additional info: I've already tried Ubuntu 14.04 and 16.04.

Also, I've found source code for mfgtools at GitHub - NXPmicro/mfgtools: Freescale/NXP I.MX Chip image deploy tools. 

A bit of looking into the code reveals that error comes from libusb: LIBUSB_ERROR_TIMEOUT (-7).

Can someone confirm that libMfgToolLib.so works on any Linux setup with QWKS SCM board?

Thanks

Outcomes