AnsweredAssumed Answered

imx6ul CSI can't disable csi_mclk

Question asked by tony zhang on Jan 9, 2017
Latest reply on Jul 13, 2017 by tony zhang

lm98714_data.sensor_clk = devm_clk_get(dev, "csi_mclk");

retval = of_property_read_u32(dev->of_node, "mclk",&lm98714_data.mclk);

retval = clk_set_rate(lm98714_data.sensor_clk, lm98714_data.mclk);




See the code show above, I find that after I disable the csi_mclk clk, the imx6ul port(CSI_MCLK) still create wave, I don't know how to disable this clk.