AnsweredAssumed Answered

i.Mx6 HAB Invalid address

Question asked by ramakrishna rao on Jan 4, 2017

Hi All,

                In  one of our project we are using imx6solo and yocto build system(jethro_4.1.15-1.1.0_GA)

We have requirement for HAB4 and downloaded the CST -2.3.2 tool from NXP server.

We are enable the HAB at U-Boot and kernel(/sys/fsl_otp).

 

Now we write the  mw 021bc2460 2 for  enable the HAB on engineering mode

When  we use the hab_status at U-boot prompt it shows “ Secure boot enabled”

When we trying for hab_auth_image we are getting the following error

Can you please help for fixing this issue .

 

 

=> hab_auth_img  0x12000000 0x559000

 

Authenticate image from DDR location 0x12000000...

 

ivt_offset = 0x559000, ivt addr = 0x12559000

Dumping IVT

12559000: 402000d1 12001000 00000000 00000000    .. @............

12559010: 00000000 12559000 12559020 00000000    ......U. .U.....

Dumping CSF Header

12559020: 404800d4 000c00be 00001703 48000000    ..H@...........H

12559030: 020c00be 01000009 88040000 000c00ca    ................

12559040: 0000c501 dc070000 000c00be 02000009    ................

12559050: e0090000 001400ca 0000c502 340d0000    ...............4

 

Secure boot enabled

 

HAB Configuration: 0xf0, HAB State: 0x66

 

--------- HAB Event 1 -----------------

event data:

     0xdb 0x00 0x08 0x41 0x33 0x22 0x0a 0x00

 

--------- HAB Event 2 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x74 0x00

     0x00 0x00 0x00 0x20

 

--------- HAB Event 3 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x74 0x20

     0x00 0x00 0x00 0x01

 

--------- HAB Event 4 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x80 0x00

     0x00 0x00 0x00 0x04

 

Calling authenticate_image in ROM

     ivt_offset = 0x559000

     start = 0x12000000

     bytes = 0x55b020

 

Secure boot enabled

 

HAB Configuration: 0xf0, HAB State: 0x66

 

--------- HAB Event 1 -----------------

event data:

     0xdb 0x00 0x08 0x41 0x33 0x22 0x0a 0x00

 

--------- HAB Event 2 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x74 0x00

     0x00 0x00 0x00 0x20

 

--------- HAB Event 3 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x74 0x20

     0x00 0x00 0x00 0x01

 

--------- HAB Event 4 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x00 0x90 0x80 0x00

     0x00 0x00 0x00 0x04

 

--------- HAB Event 5 -----------------

event data:

     0xdb 0x00 0x14 0x41 0x33 0x0c 0xa0 0x00

     0x00 0x00 0x00 0x00 0x12 0x55 0x90 0x00

     0x00 0x00 0x00 0x20

 

And also pls help for signing the SPL image.

 

 

 

Thanks & Regards

Kilaru Ramakrishna Rao

Original Attachment has been moved to: genIVT.zip

Original Attachment has been moved to: habimagegen.zip

Original Attachment has been moved to: habUImageGen.zip

Original Attachment has been moved to: u-boot.csf.zip

Original Attachment has been moved to: uImage-signed-pad.bin.zip

Original Attachment has been moved to: u-boot-signed-pad.bin.zip

Original Attachment has been moved to: uImage.zip

Original Attachment has been moved to: uImage.csf.zip

Original Attachment has been moved to: u-boot.img.zip

Outcomes