AnsweredAssumed Answered

Enable PU regulator

Question asked by Niklas Molin on Dec 31, 2016
Latest reply on Jan 3, 2017 by Niklas Molin

Hi.

I wonder if there is a quick way to enable the PU regulator, either in the device tree or from user space?

For the moment it seems like the PU regulator is disabled (during the startup I can see it first enables and then disables it).

Since it's disabled, the VDDPU won't follow the VDDSOC (which it should according to the datasheet), when changing the frequency (in the imx6q-cpufreq.c file).

If I don't have an application using the VPU, will it automatically disabled the VDDPU?

 

Thanks,

Niklas

Outcomes