Andrei Salomao

Flashing blank MC13213

Discussion created by Andrei Salomao on Jul 9, 2008
Latest reply on Jul 24, 2008 by Zahar Raskin
Ok guys, after hours and hours trying to flash my module (thousand of "power cycling" in CodeWarrior using P&E Multilink) I still just ca't get it working. It doesn't enter in Background Debug Mode. I tried power off and power on while holding BKGD pin low, but no success... I read a lot of posts here about flashing blank devices and I see that is not just me with this problem. I have the following voltage in the pins:
 
3V in VBATT and VDDINT (the power supply is good, no significant noise);
 
0V in VDDVCO (?) (I think it's because MCU keeps executing COP reset (blank device), right?);
 
~0.3V in VDDA, VDDLO1 and VDDLO2 (?) (again, is COP reset the cause?);
 
~2V in reset pin (?) (this is really strange, but again I'm blaming COP reset :smileyhappy: );
 
3V in BKGD (I tried the power cycle holding BKGD low);
 
Well, anyone please help me! I'm working in solder issues too, but it appears that every connection is fine. Thanks in advance!
 
DedsBee

Outcomes