AnsweredAssumed Answered

G2D plugins don't work

Question asked by Pierre-Olivier Huard on Dec 23, 2016
Latest reply on Dec 26, 2016 by igorpadykov

Hello,

I'm trying to make G2D plugins from gstreamer-imx work with my imx6q. I work on Yocto, fido branch, with 3.14.38 kernel.

These plugins are from https://github.com/Freescale/gstreamer-imx. When I try to run gst-launch-1.0 imxv4l2videosrc ! imxg2dvideosink I get the following error :

 

g2d_alloc: alloc memory fail with size 16!
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
Freeing pipeline ..

 

With more debug :

0:00:00.540714000   425   0x549400 INFO     imxphysmemallocator phys_mem_allocator.c:62:gst_imx_phys_mem_allocator_init:<GstImxPhysMemAllocator@0x54d908> initializing physical memory allocator
g2d_alloc: alloc memory fail with size 16!
0:00:00.556959667   425   0x549400 ERROR        imxg2dallocator allocator.c:59:gst_imx_g2d_alloc_phys_mem:<imxg2dallocator0> could not allocate 16 bytes of physical memory
0:00:00.557108000   425   0x549400 WARN     imxphysmemallocator phys_mem_allocator.c:154:gst_imx_phys_mem_allocator_alloc:<imxg2dallocator0> could not allocate memory block with 16 bytes
0:00:00.557213000   425   0x549400 WARN              GST_BUFFER gstbuffer.c:739:gst_buffer_new_allocate: failed to allocate 16 bytes

I posted an issue on the github, but it's not solved.

I tried to change the CMA value, already to 320M to other values, but this the same error.

a part of my kernel configuration :

CONFIG_MXC_GPU_VIV=y

CONFIG_CMA_SIZE_MBYTES=320
CONFIG_CMA_SIZE_SEL_MBYTES=y

CONFIG_CMA_ALIGNMENT=8
CONFIG_CMA_AREAS=7

CONFIG_DMA_CMA=y

CONFIG_DMA_SHARED_BUFFER=y

I think it would be a kernel missconfiguration. I work on another iMX (DL) and these plugins just work fine with yocto fido. Any thougts about kernel missing configuration?

Best Regards

Outcomes