AnsweredAssumed Answered

cross_compile QT5.6.0 for imx6ull using arm-none-linux-gnueabi-

Question asked by sheng huang on Dec 22, 2016
Latest reply on Dec 22, 2016 by jimmychan

hi,

   I want to transplant the QT5.6.0 to our custom imx6ull board, using arm-none-linux-gnueabi to cross complie, but in the first setup, it go to fail! errors is such as follow.

   In the qtbase/mkspecs/linux-arm-gnueabi-g++/qmake.conf, 

 1. I do not know what is the --sysroot, becaurse int the paht of /fsl-linaro-toolchain/arm-fsl-linux-gnueabi/, sub-folder has so many files such as .

2. in the ../fsl-linaro-toolchain/ , it can support -mfloat-abi=softfp or -mfloat-abi=hard, when i use -mfloat-abi=softfp, it can not find some include file xxx.h, so i use -mfloat-abi=hard, but it also appear some erros such as VFP fail or can not merger some thing. so what can i do?

 

3. cannot execute binary file: Exec format error and qtbase/bin/qmake: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.3, for GNU/Linux 2.6.31, not stripped. is this meaning i use /lib/ld-linux.so.3 is not right? so how can i specify what 'ld' to compile the qt5.6.0?

Outcomes