AnsweredAssumed Answered

Arm Linker Option problem

Question asked by vines on Dec 21, 2016
Latest reply on Dec 26, 2016 by ZhangJennie

Hi All,

 

First off, to the moderators of this forum, if this topic is off to this page please move it accordingly. Thanks.

 

I recently played around with some GCC compiler and tried to incorporate unit test tool into Codewarrior. When I was done, I tried to recompile a working project (created under CW compiler) again and is giving me an error. The error is: 

 

The above error is generated only in CW 10.4 where I played around with creating projects with MinGW.

 

I have another IDE of CW on my PC which is 10.6. If I compile the same project on 10.6 IDE, I won't have this problem. Hence, I dig in deeper with regards to the difference in settings between the 2. I found out that in CW 10.4, there is additional lines on the ARM Linker All options. Please see figure below. This is causing the problem because it tries to access a file that is no longer there because I already deleted that resource. 

 

My question is how can I remove the lines highlighted in red above? This is not present in my 10.6 IDE. The reason why I still maintain my 10.4 IDE is because I cannot debug my project if I use 10.6. But that is a different story on another day. I just want my code to compile again in the 10.4 IDE. My suspect is that when I Downloaded/link MinGW it mess up the path or something. I maybe wrong.

 

Appreciate any help I can get. 

 

Thanks.

Outcomes