AnsweredAssumed Answered

Is mpc8309twr flexcan support is available in 3.4 kernel ?

Question asked by vineeth paraprath on Dec 16, 2016
Latest reply on Dec 20, 2016 by vineeth paraprath

Hi I am using mpc8309twr board. I want to configure the flexcan of twr board. I am using linux 3.4.113 kernel.

In drivers/net/can/flexcan.c I found compatible field only as "fsl,p1010-flexcan", Is there a support available for twr board  ["fsl,mpc830x-flexcan"]  ?

My dts entry is shown below, I am using only can4 in twr board.

can0@2a000 {
compatible = "fsl,mpc830x-flexcan";
cell-index = <3>;
reg = <0x2a000 0x1000>;
interrupts = <10 0x8>;
interrupt-parent = <&ipic>;
};

 

I have patch for flexcan driver in 2.6 kernel, that I cannot use in 3.4 kernel. I hope my question is clear and expecting a reply.

Outcomes