AnsweredAssumed Answered

Error using Realtek RTL8723AE Wi-Fi mini-PCIe on I.MX7

Question asked by Danny Vaiselberg on Dec 14, 2016
Hello,

 

When connecting PCI/PCIe devices to I.MX7 evaluation board, devices do not work for multiple reasons.

 

We tried to connect multiple devices, such as Realtek RTL8723AE Wi-Fi (rtlwifi module, included in Linux kernel) and National Instruments GPIB (tnt4882 module), and each device didn't work for various reasons. the Wi-Fi Realtek RTL8723AE didn't work because of RF-Kill hardware block, the GPIB was registered but did not actually operate the GPIB.

 

Trying the Wi-Fi card, we discovered that the PCI configuration space works, but mapped memory access returns all one-bit (FFFFFFFF...).
We tried to enable various CONFIG_PCI configurations in the kernel didn't change the situation.
dmesg gives seemingly correct results, BARs are assigned correctly. However, viewing the memory (both with mmap in user-space and ioremap in kernel-space) yields all one bits in the memory region that should be mapped. Upon inspection with a logic analyzer, no messages are sent through PCI for memory space . lspci, however, does send messages over PCI to retrieve configuration space correctly.

 

Any ideas why this shouldn't work?
Attached lspci results for Realtek Wi-Fi, /proc/config.gz, /proc/iomem, and dmesg output.

 

Original Attachment has been moved to: imx_7pcimemoryerror.zip

Outcomes