AnsweredAssumed Answered

RTC PC85263A oscillator not running

Question asked by BALAGANESH A on Dec 10, 2016
Latest reply on Dec 10, 2016 by BALAGANESH A

Hi everyone,

Ur suggestions are valued,

I am currently working with the RTC Chip PC85263A

I can very well write and read the registers inside the chip, but the actual lies problem lies in the oscillator

I have disabled the STOP bit in the Stop register 2Eh,

But still the Oscillator is not running and the timing registers are not getting updated

Also Im not getting any clock in the CLKOUT pin

I have tried replacing crystals (both smd and through hole watch crystals)

 

On time like a miracle, i got the entire setup worked perfectly, but then i got delay in time updation,

Thinking that the problem is in the crystal, i replaced the crystal, but met with the problem wat i experienced at the start

 Hardware part i checked many times, and i feel that there is no issues

 

Is there any other initial settings that i have to do (other than software reset) ?

Outcomes