AnsweredAssumed Answered

ucc switching between fast protocols and slow protocols is not working

Question asked by Amanaganti VinodKumar on Dec 10, 2016
Latest reply on Dec 15, 2016 by Amanaganti VinodKumar

Hi All,

 

We are working on MPC8309 processor, we are using the ucc-5 for synchronus-HDLC and Asynchronous-UART purpose. Here UCC is configured in fast protocol mode for HDLC and slow protocol for UART mode.

We have verified the UCC  for UART and HDLC mode both are working fine, but whenever we are switching the UCC from fast protocol [HDLC] to slow protocol [UART] UCC is not workking.

We tried the protocol switching sequence mentioned in the QE reference manual, but it did not help. but whenever we issue a QE-RESET then from fast protocols to slow protocol switching is working.

 

But we should not issue a QE-reset command as other UCC ports are used for some other purpose and should not be disturbed.

 

We are observing below things.

1. when switching from slow protocols to fast protocols UCC is working fine in HDLC mode without  any issues

2. Whenever switching from fast protocols to slow protocols UCC_UART_UCCE_BSY interrupt is triggered and ucc stopped working, we tried re-configuring transmitter and receiver for BSY error interrupt, but still it did not help.

 

We are using the standard platform drivers provided by NXP for HDLC and UART, could you please suggest the exact flow that should be followed for switching from fast protocols to slow protocols, 

 

Your help is appreciated in  advance. it would be  great, if sample test code is provided for this switching which indicates the exact sequence.

Outcomes