AnsweredAssumed Answered

Debugging TWR-K64F120M with Ulink2 in Keil IDE

Question asked by CSMG Sarma on Dec 8, 2016
Latest reply on Dec 14, 2016 by CSMG Sarma

Dear list,

I am using ULIK2 debugger to flash/debug applications using Keil IDE for my TWR-K64F120M board. The "target driver setup" in Debug section project options was not detecting my board with default settings. After removing J39 Jumper, the TWR board was detected by the tool.

 

When I run the debug session or try to flash the application(default blinky project in the installation directory), I am seeing flash errors as in the attachment.

 

Is it possible to launch debug session with Ulink2 debugger with default jumper settings? If anyone has tried this combination(Ulink2, Keil IDE and TWR-K64F120M), request you to share the Jumper settings as I suspect that the problem lies in the jumper settings. The Ulink2 debugger is working fine as I am using it to flash and debug another Freescale K10 series mirco too. 

 

I have tried the trouble shooting steps given here.

and here.

 

Thanks in anticipation.

 

Best regards
Sarma

Attachments

Outcomes