AnsweredAssumed Answered

gstreamer1.0-plugins-bad failure

Question asked by Paul DeMetrotion on Dec 8, 2016
Latest reply on Dec 16, 2016 by gusarambula

I am in the process of migrating to the new Freescale repository linux-imx.git and upgrading the kernel to version 4.1.15 for a Yocto build project. Everything is proceeding well - I can build my u-boot and linux images and can build the core-image-minimal images. When I try to build the fsl-image-multimedia image, I get the following error:

 

ERROR: Command Error: exit status: 1 Output:
Applying patch 0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch
patching file gst-libs/gst/base/Makefile.am
patching file gst-libs/gst/video/Makefile.am
Hunk #1 FAILED at 19.
1 out of 1 hunk FAILED -- rejects in file gst-libs/gst/video/Makefile.am
Patch 0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch does not apply (enforce with -f)
ERROR: Function failed: patch_do_patch
ERROR: Logfile of failure stored in: /home/pauldemet/fsl-arm-yocto-bsp-tesla/build-c421/tmp/work/cortexa9hf-vfp-neon-mx6qdl-poky-linux-gnueabi/gstreamer1.0-plugins-bad/1.6.0-r0/temp/log.do_patch.15994
ERROR: Task 1324 (/home/pauldemet/fsl-arm-yocto-bsp-tesla/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.0.bb, do_patch) failed with exit code '1'

 

The following link discusses this error over a year ago but I cannot find the resolution.

 

[meta-fsl-arm] gstreamer1.0-plugins-bad failure - Patchwork 

 

Anybody have the answer???

Outcomes