AnsweredAssumed Answered

KSDK2 USB CDC do not work with HTerm and QSerialport

Question asked by Maximilian Niedernhuber on Nov 8, 2016
Latest reply on Nov 8, 2016 by Maximilian Niedernhuber

Hello,

I have a strange behavior with QSerialport and HTerm and USB CDC on a KL26Z256. I tried serveral examples (usb_device_composite_cdc_msc_lite, usb_device_cdc_vcom_lite, usb_device_cdc_vcom) all of these have the same issue.

First of all install the driver and everything is ok ... there are one new COM port. So lets open the comport and send one byte with HTerm nothing happends no echo nothing. Now the virtual comport is in some strange state.

It is not possible to send or receive something. If you close the comport and open it with another terminal application which usually do not cause this issue like docklight the com port is still frozen.

After replugging the device the comport is now useable again with docklight or hyperterminal. But if you open the port with HTerm the comport is again in a unuseable state.

With other CDC devices like LPC1765 - everything works great.

So it looks like these applications make something that cause this issue on KL26Z256 with KSDK2.0.

I tried to debug this issue with Wireshark it seems there are some malformed packets.

 

Packet No. 2765 for "USB_Dump_with_QSerialport"
Packet No. 1053 for "USB_Dump_with_Docklight"

 

I hope this is a known phenomenon which can be fixed.

 

 

 

Thanks a lot and Best regards.

Original Attachment has been moved to: USB_Dump_with_QSerialport.pcapng.zip

Original Attachment has been moved to: USB_Dump_with_Docklight.pcapng.zip

Outcomes