AnsweredAssumed Answered

imx6ul custom board nand programming

Question asked by chandra sekhar on Nov 7, 2016
Latest reply on Nov 19, 2016 by chandra sekhar

I am having a custom board based on IMX6UL, we are using NAND. I have modified all the changes mentioned in 

How-To use NAND boot on i.MX6UL EVK board this page

Below is the Log which I got from debug port.It is not proceeding further Starting Kernel. QAfter this mfgtool says "No device connected". Can anyone point what may be the issue.


U-Boot 2015.04-imx_v2015.04_3.14.38_6ul_ga+g5d63276 (Nov 08 2016 - 10:04:09)

CPU: Freescale i.MX6UL rev1.0 at 396 MHz
CPU: Temperature 44 C
Reset cause: POR
Board: PLUM
I2C: ready
DRAM: 512 MiB
NAND: 128 MiB
MMC: FSL_SDHC: 0
*** Warning - bad CRC, using default environment

Display: TFT43AB (480x272)
Video: 480x272x24
In: serial
Out: serial
Err: serial
Net: Phy 1 not found
PHY reset timed out
FEC1
Error: FEC1 address not set.

Boot from USB for mfgtools
Use default environment for mfgtools
Run bootcmd_mfg: run mfgtool_args;bootz ${loadaddr} ${initrd_addr} ${fdt_addr};
Hit any key to stop autoboot: 0
Kernel image @ 0x80800000 [ 0x000000 - 0x529378 ]
## Loading init Ramdisk from Legacy Image at 83800000 ...
Image Name: fsl-image-mfgtool-initramfs-imx_
Image Type: ARM Linux RAMDisk Image (gzip compressed)
Data Size: 7485694 Bytes = 7.1 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
## Flattened Device Tree blob at 83000000
Booting using the fdt blob at 0x83000000
Using Device Tree in place at 83000000, end 8300b82b

Starting kernel ...

Outcomes