AnsweredAssumed Answered

How to support QT applications in IMX7d Sabre board?

Question asked by Guoxiong Jiang on Nov 8, 2016
Latest reply on Nov 9, 2016 by Guoxiong Jiang

Hi, 

 

How to support QT5 applications based on X11 or wayland backend in imx7d Sabre board?

the software version: fsl-yocto-L4.1.15_1.2.0-ga

First, I made qt5 sdk using the command "bitbake meta-toolchain-qt5", installed the SDK package,

then compiled QT project, but can't work well.

 

source /opt/fsl-imx-wayland-tcqt5/4.1.15-2.0.0/environment-setup-cortexa7hf-neon-poky-linux-gnueabi
developer@developer-T440 ~/qt5/examples/gui/analogclock $ qmake analogclock.pro 

 

Cannot read /opt/fsl-imx-wayland-tcqt5/4.1.15-2.0.0/sysroots/cortexa7hf-neon-poky-linux-gnueabi/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory
 

Would you like to give me some advice? Thanks a lot in advance!

Regards,

Jiang

Outcomes